My Health+ Login Features Currently Unavailable
Incident Report for My Health+
Resolved
This incident has been resolved.
Posted Oct 11, 2021 - 10:54 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2021 - 09:50 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 11, 2021 - 09:46 MDT
Investigating
At this time users are unable to login into the My Health+ website or mobile apps. We are investigating the cause of the issue. We apologize for any inconvenience this has caused.
Posted Oct 11, 2021 - 09:36 MDT
This incident affected: My Health+ Mobile Applications (Apple Mobile App, Android Mobile App) and My Health+ Website.