My Care Team Issues

Incident Report for Intermountain Health App

Identified

Support teams met with the vendor Kyruus and found a data mapping issue. The vendor made an update to how they send the provider ID's. They have agreed to support the previous method so we can receive/read the data on our end. Developers are still looking at what can be done to the provider service on our end to resolve the issue.
Posted Jul 15, 2025 - 10:31 MDT

Investigating

Care Team may not be displayed fully for some users. Support teams are investigating.
Posted Jul 14, 2025 - 09:06 MDT
This incident affects: Online Patient Portal.