Limitations with Online Scheduling
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 21:42 MST
Identified
At this time, users may experience issues with sign-in, online scheduling, and some My Care Team functions. We are investigating the cause of the issue. We apologize for any inconvenience this has caused.
Posted Jan 13, 2025 - 19:02 MST
This incident affected: Mobile Applications (Apple Mobile App, Android Mobile App).