Biometric Sign In Issues
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 14:09 MDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2024 - 17:22 MDT
Investigating
We're sorry, we are currently experiencing an issue with biometric sign in that may affect your experience. If you are affected, please use your username and password to sign in. Thank you for your patience
Posted Jul 23, 2024 - 16:59 MDT
This incident affected: Mobile Applications (Apple Mobile App).