Login issues
Incident Report for Intermountain Health App
Resolved
The incident has been resolved.
Posted Mar 20, 2024 - 13:41 MDT
Monitoring
The issue has been identified and a fix applied. We are monitoring the performance.
Posted Mar 20, 2024 - 11:55 MDT
Investigating
Presently, we are encountering difficulties with user logins. Our team is actively investigating the root cause of this matter. We sincerely apologize for any inconvenience this may have generated.
Posted Mar 20, 2024 - 11:49 MDT
This incident affected: Online Patient Portal and Mobile Applications (Apple Mobile App, Android Mobile App).