Patient Portal Appointment Booking Experience Degraded
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Jan 30, 2025 - 10:04 MST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2025 - 10:04 MST
Investigating
Users may experience problems when they try to book appointments. We are actively investigating the issue. We apologize for any inconvenience this has caused.
Posted Jan 27, 2025 - 09:52 MST
This incident affected: Online Patient Portal and Mobile Applications (Apple Mobile App, Android Mobile App).