Provider and Billing Features

Incident Report for Intermountain Health App

Resolved

This incident has been resolved.
Posted May 28, 2025 - 18:38 MDT

Update

We are continuing to investigate this issue.
Posted May 28, 2025 - 17:35 MDT

Investigating

Notification and Provider Impacted. Investigating now.
Posted May 28, 2025 - 17:17 MDT
This incident affected: Online Patient Portal, Mobile Applications (Apple Mobile App, Android Mobile App), and Individual Features & Services (Billing Features, Get Care Features, Text Message Notifications).