My Health+ Website and App Currently Unavailable
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 17:42 MDT
Identified
At this time the website and app are unavailable. A database is currently being updated and will be available shortly. We apologize for any inconvenience this has caused.
Posted Oct 04, 2021 - 17:16 MDT
This incident affected: Online Patient Portal and Mobile Applications (Apple Mobile App, Android Mobile App).