Limitations with Online Scheduling and Messages

Incident Report for Intermountain Health App

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 14:41 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 13:30 MDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2025 - 13:30 MDT

Investigating

At this time, users may experience issues with online scheduling functionality and access to their messages. We are investigating the cause of the issue. We apologize for any inconvenience this has caused.
Posted Apr 21, 2025 - 08:33 MDT
This incident affected: Online Patient Portal and Mobile Applications (Apple Mobile App, Android Mobile App).