My Health+ Features Degraded
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 00:33 MST
Investigating
My Health+ is experiencing an outage of certain Classic services and features. Currently users may experience the inability to book an appointment, register a new account, retrieve lab results, retrieve insurance information and retrieve provider information. Other errors may be present during this time, and they will be identified as the investigation continues.
Posted Nov 14, 2021 - 21:50 MST
This incident affected: Online Patient Portal, Mobile Applications (Apple Mobile App, Android Mobile App), and Individual Features & Services (Get Care Features).