E-visits degradation.

Incident Report for Intermountain Health App

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 14:49 MST

Investigating

Degraded experience when submitting E-visits
Posted Feb 06, 2025 - 12:38 MST
This incident affected: Online Patient Portal and Mobile Applications (Apple Mobile App, Android Mobile App).