Online scheduling is temporarily unavailable. Please contact your provider's office to schedule an appointment.

Incident Report for Intermountain Health App

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 09:08 MDT

Investigating

Online scheduling is temporarily unavailable. Please contact your provider's office to schedule an appointment.
Posted Aug 06, 2025 - 08:27 MDT
This incident affected: Online Patient Portal, Mobile Applications (Apple Mobile App, Android Mobile App), and Individual Features & Services (Get Care Features).