Patient Portal Online Scheduling Experiencing Issues
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 16:05 MDT
Investigating
We are currently investigating this issue.
Posted Jul 23, 2024 - 14:21 MDT
This incident affected: Online Patient Portal.