Partial Outage of Intermountain Health App Features
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 14:50 MDT
Update
We are continuing to investigate this issue.
Posted Mar 18, 2024 - 14:50 MDT
Investigating
Intermountain Health App is currently experiencing inability to display upcoming appointments and My Care Team.
The issue is under investigation. Other errors may be present and identified as the investigation continues.
Thank you for your understanding.
Posted Mar 18, 2024 - 12:44 MDT
This incident affected: Online Patient Portal, Mobile Applications (Apple Mobile App, Android Mobile App), and Individual Features & Services (Get Care Features).