Partial Outage of Intermountain Health App Features
Incident Report for Intermountain Health App
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 17:01 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 26, 2024 - 17:01 MDT
Investigating
Intermountain Health App is currently experiencing issues with billing features.
The issue is under investigation. Thank you for your understanding.
Posted Apr 26, 2024 - 13:56 MDT
This incident affected: Online Patient Portal, Mobile Applications (Apple Mobile App, Android Mobile App), and Individual Features & Services (Billing Features).